Please login or register.

Login with email, password and session length
 

News:

Happy 15th Birthday, Freedom Force!


Author Topic: Skoped nif reverts to original form when copied?  (Read 186 times)

Offline SickAlice

  • Virtual prophet and aspiring beet farmer
  • Hero Member
  • Posts: 1836
  • bing cherry
    • The Litterbox aka MeanJellybean
Skoped nif reverts to original form when copied?
« on: August 27, 2016, 02:24:07 PM »
Never encountered this one before. So I skoped male_hunter, removing/deleting all of the original 3d object data from the nif and brought in new stuff as well changed the textures and coordinates. It all went fine. I then made a copy of that directory (all permissions prechecked) for uploading. However the copy reverted back to the original male_hunter nif. My solution was to open Nifskope, open the modified nif from it's directory and save it over the copy in it's new directory (again everything checked in properties). I've never seen this happen though and was wondering if anyone knows what does that? I'm using Windows 10 currently.

Offline daglob

  • Shape-Shifting Silly-Putty Android
  • Hero Member
  • Posts: 7281
  • Da Glob
Re: Skoped nif reverts to original form when copied?
« Reply #1 on: August 27, 2016, 02:44:07 PM »
I didn't have that happen, but for the first week or so after I upgraded to WX, pieces that I scoped from one mesh to another didn't show up in the finished scope in either CTool or the game, just in Nifscope. That changed after an update, so I have no idea what was going on.

Gremlins... Windows 10 gremlins...

Actually, at a guess, it wasn't letting you save over the original mesh. I can't use Nifconvert anyplace but the Nifconvert directory, despite being the administrator, and telling it "yes" when it asks me if I want the program to make changes to my PC AND running it in Windows XP Compatibility mode because it won't save over the original mesh.

I am supposed to be set up as a power user on this computer, but sometimes I wish there was a "leave me the hell alone" mode...
« Last Edit: August 27, 2016, 02:52:52 PM by daglob »

Offline Cyber Burn

  • Hero Member
  • Posts: 7798
Re: Skoped nif reverts to original form when copied?
« Reply #2 on: August 27, 2016, 08:47:17 PM »
I actually had to deal with that when I first started using Windows 10. Below is the File Path for one of my Skopes, I would make changes to the Nif File, and the Nif would repeatedly either not save, or if I saved it elsewhere to back it up, it reverted back to the original Nif File.

C:\Program Files (x86)\Irrational Games\Freedom Force vs The 3rd Reich\Custom\Art\library\Characters\JSA_Doctor_Midnight_McNider_FFvt3R_V1

After a lot of frustration, and trial and error, what I ended up doing, was, on each File pertaining to the Skope, I would Right Click, open up Properties, uncheck the Read Only Attribute, and made sure it applied to all Subfolders and Files. It was very time consuming, and I often had to do it multiple times, but thankfully I don't seem to have this issue anymore.


Basically, I had to do this for each one of these Folders, plus the Character.Nif for EVERY Skope I worked on until the kinks worked themselves out.

1.) Program Files (x86)
2.) Irrational Games
3.) Freedom Force vs The 3rd Reich
4.) Custom
5.) Art
6.) library
7.) Characters
8.) JSA_Doctor_Midnight_McNider_FFvt3R_V1
9.) Character.Nif

This is just what worked for me, so I can't guarantee that it's an all around fix for everyone.